正在载入...

在网络程序中使用ajax库已经是很普遍的事情了。特别是wordpress等博客主题(theme)使用ajax以提升用户体验更是屡见不鲜了。jquery应该选择什么样的版本,对于那些只是代码爱好者(非专家)来说,速度是关键。常用而稳定的jquery版本有:1.2.3、1.2.6、1.3.0、1.3.1、1.3.2等。Google AJAX 库 API提供jquery库调用服务。

Google AJAX 库 API是一种内容分布网络,可载入jquery库。通过使用调用js相同的方法,就能迅速从google全球任何位置访问jquery库。常用版本对应调用地址分别是:
http://ajax.googleapis.com/ajax/libs/jquery/1.2.3/jquery.min.js
http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js
http://ajax.googleapis.com/ajax/libs/jquery/1.3.0/jquery.min.js
http://ajax.googleapis.com/ajax/libs/jquery/1.3.1/jquery.min.js
http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js

既然速度是关键,在“够用”的基础上:不同版本的jquery库的大小不同,当然选择相对较小的,速度就快一些。另外一方面,使用范围比较广的框,也能提升加载效率,当然这不是p2p软件,用的人多速度就快。而是大量网站使用的同一版本的jquery库,用户在浏览你的网站之前,加载了相同版本的jquery的就大,如果真的是加载了相同的版本jquery库,那恭喜你,你网站可以使用已经加载好的jquery库了(哈哈,捡现成的用)——此,所谓人多力量大也。

在上述不同版本jquery库的google api 调用地址“全部”,输入google.com.hk搜索“中文网页”(进入你的网站的用户不会是那些浏览非中文网页的居多吧?),结果是:
排第一的是:“http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js”有3340个结果。
排第二是:“http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js”,有1140个结果。

其他的都在几百和几十这个数量级。

因此,我们考虑选择1.3.2或者1.2.6版本。希望大家都用1.3.2——还是那句话,人多力量大。

——本博(wentong.org)使用的就是1.3.2版本。

最新更新:2011.10.12《WordPress载入jQuery库Google/微软/sinaapp三种方法比较

本文链接:

关键词:ajax, google, jQuery, WordPress, 代码,

(全文完        )

Comments

Trackbacks/Pingbacks

  1. 当前加载google ajax库的jquery流行版本是1.4.2 | 文通博客 --- 2010/11/24

13 条评论(网友评论:12 条,博主回复:0 条, 被转载:1 次)快速评论

  1. 我的博客 我都不知道哪里可以修改这个

    • 鱼此鱼已

      @皇家元林 看了你博客代码:jquery/jquery.js?ver=1.3.2 就是调用1.3.2版本,完全可以使用用google api 库。

  2. 这玩意在哪里啊?

    • 鱼此鱼已

      @皇家元林 在你正在使用的主题的 头部 header.php :script type=’text/javascript’ src='(具体代码根据你主题而定)wp-includes/js/jquery/jquery.js?ver=1.3.2′ ,修改为:script type=’text/javascript’ src=’http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js’ ,——,呵呵,还有问题找google。

  3. 让他

    问的我去

  4. lee

    新版本的wordpress 3.0.1 如何修改?!望指教!!

    • 鱼此鱼已

      @lee 这跟wordpress的版本无关的。在你正在使用的主题的 头部 header.php :script type=’text/javascript’ src=’(具体代码根据你主题而定)wp-includes/js/jquery/jquery.js?ver=1.3.2′ ,修改为:script type=’text/javascript’ src=’http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js’ (或者添加该代码)

      • lee

        打开WP 3.0.1 默认的风格你就知道, header.php 根本不存在你说的这个。

        不过,已经用其它方法解决了!

  5. 好东西,正在学习jquery

    • 鱼此鱼已

      @ZCMHI 现在jquery流行版本是1.4.2了。这个文章很老了。

  6. 兄弟你的博客有问题,有乱码!

    谢谢你的地址!

    • 鱼此鱼已

      是主题文件的编码问题。换了服务器,就出现乱码。现在还没有空去理会呢。

你需要 登录 才可以回复.