How should I deal with “package 'xxx' is not available (for R version x.y.z)” warning?

How should I deal with “package 'xxx' is not available (for R version x.y.z)” warning?

I tried to install a package, usinginstall.packages("foobarbaz")but received the warningWarning message:package 'foobarbaz' is not available (for R version x.y.z)Why doesn't R think that the package is available?See also these questions ref

How do I add files in Git to the path of a former submodule?

How do I add files in Git to the path of a former submodule?

I have a project that used to contain a submodule, at path mysubmodule. I installed the latest Git from source (1.8.3-rc2) and ran git submodule deinit mysubmodule. I then deleted the .gitmodules file and committed the change. I also del

MVC5: Enum radio button with label as displayname

MVC5: Enum radio button with label as displayname

I have these enumspublic enum QuestionStart{ [Display(Name="Repeat till common match is found")] RepeatTillCommonIsFound, [Display(Name="Repeat once")] RepeatOnce, [Display(Name="No repeat")] NoRepeat}public enum Quest

How can I get my jasmine tests fixtures to load before the javascript considers the document to be “

How can I get my jasmine tests fixtures to load before the javascript considers the document to be “

I am fairly certain that the issue is that the jquery bindings set to run on $(document).ready do not have the fixture html available to them. So when my events occur that are intended to make a change to the DOM via a jquery function, not

Why am I getting Unexpected token '\\u0000' when using npm install -g package

Why am I getting Unexpected token '\\u0000' when using npm install -g package

This is probably a Windows specific issue but I haven't found any information when googling this issue. I had been using ionic framework which relies on Cordova (or Phonegap). However, the problem is not specific to any of these packages.

Why relative path doesn't work in Ruby require

Why relative path doesn't work in Ruby require

I'm starting learning Ruby, one thing that I don't understand, why relative path for require directive doesn't work in ruby. It's something that works almost in every scripting language that I now (JSP, PHP...). I explain with a real exampl

Keep x number of files and delete all others - Powershell

Keep x number of files and delete all others - Powershell

I am trying to write a script that will look through a set of folders and keep only the last 10 files. The files in each folder could be created daily, weekly or monthly. I need the script to keep the 10 most recent copies regardless of the

Java -classpath option

Java -classpath option

Will the use of -classpath option with java, add to or replace the contents of the CLASSPATH env variable? 1:Using the classpath variable it overrides the CLASSPATH of Environment variable but only for that session. If you restart the ap

Error installing python-snappy: snappy-c.h: No such file or directory

Error installing python-snappy: snappy-c.h: No such file or directory

I am using amazon ec2 ubuntu 11.04 server sudo pip install python-snappy also I tried to downloaded package and entered "sudo python setup.py install"I got the error: running build running build_ext building 'snappy' extension gcc -pthr

Add the installation prefix of “Qt5Widgets” to CMAKE_PREFIX_PATH

Add the installation prefix of “Qt5Widgets” to CMAKE_PREFIX_PATH

I don't know a lot about cmake, I'm trying to build a client using cmake and Qt. Getting the following error: CMake Error at alethzero/CMakeLists.txt:26 (find_package): By not providing "FindQt5Widgets.cmake" in CMAKE_MODULE_PATH this p

Change the root context to other folder in tomcat 6

Change the root context to other folder in tomcat 6

I want to change the context of my deployed web application. Currently it is accessed by the url www.app.mysite.com/dashboard But i want to change it to www.app.mysite.com/application/dashboard I went through post to change the root context

python 'bigfloat' package installation issues

python 'bigfloat' package installation issues

I'm trying to get the package 'bigfloat' installed on my Mac (OS X 10.8.4), and I'm running into some issues. The package 'bigfloat' requires two other dependencies: 1) mpfr, and 2) gmp.I've installed gmp here: http://gmplib.org/ checkin

How can I display an image in the Applet?

How can I display an image in the Applet?

I have an image and I want to display it in the applet, The problem is the image wont display. Is there something wrong with my code?Thanks...Here's my code :import java.applet.Applet;import java.awt.*; public class LastAirBender extends Ap

Generate CSV sample iphone app/code

Generate CSV sample iphone app/code

Does anyone have a sample app or some sample code to generate a CSV file on iOS? 1:My CHCSVParser will both read and write CSV files on OS X and iOS. It comes with some examples of how to use it. 2:Here is a simple code to generate C

Tomcat server absolute file access in war webapp

Tomcat server absolute file access in war webapp

I have a Spring webapp whose .war file has been uploaded to a Tomcat server. Most of the basic functions are working as intended - page views and form submission. My problem now is that my webapp needs to read and write files and I am cluel

Compile libjpeg with mingw

Compile libjpeg with mingw

I finally setup mingw and msys and now I want to compile libjpeg. I downloaded the latest libjpeg sources from the projekt page (jpeg-8d) and extracted the files.Then I ran the configure command like this:./configure --build=x86_64-w64-ming

Arquillian Embedded Glassfish Certificate Expired

Arquillian Embedded Glassfish Certificate Expired

On Aug 14th, the gtecybertrust5ca certifcate used by Glassfish expired causing my Arquillian tests to print errors.This problem is similar to this one: Certificate has expired” in log by starting Glassfish 3.1.2 except, I am using the Embed

Android AOSP - Definition of scan interval and scan window in android source code

Android AOSP - Definition of scan interval and scan window in android source code

I have downloaded the AOSP Source code for Lollipop 5.0. In api level 21, under bluetooth low energy scan settings there are three options for scanning the ble devices- SCAN_MODE_BALANCED, SCAN_MODE_LOW_LATENCY, SCAN_MODE_LOW_POWER. Are the

How to compile the smallest possible V8 library for Windows?

How to compile the smallest possible V8 library for Windows?

I'm making a game engine for school, and I want to use Google's V8 to allow for JavaScript scripting in-engine. The engine is written using Visual Studio 2013, and as the final game must not exceed 50MB, I want to keep the V8 filesize impac

Meteor in Git Shell (mingw)

Meteor in Git Shell (mingw)

I am trying to do the tutorial for Meteor JS but I can't get it to work properly using the Git Shell that comes with Github for Windows. It can't find the meteor command. It works in cmd and it is in the Windows environment path. What am I

How to give package names to django javascript_catalog view?

How to give package names to django javascript_catalog view?

From django documentation: js_info_dict = { 'packages': ('your.app.package',), } urlpatterns = patterns('', (r'^jsi18n/$', 'django.views.i18n.javascript_catalog', js_info_dict), ) Each string in packages should be in Pyth

Installing a remote Tomcat server in Eclipse

Installing a remote Tomcat server in Eclipse

I want to deploy and debug a local web application using a remote instance of Eclipse. I went through the normal "Create a server" wizard and specified my hostname as show below:However, the next step requires I specify a local tomcat direc

Symfony Cache doctrine/orm/Proxies failed to open stream /Proxy/AbstractProxyFactory.php on line 209

Symfony Cache doctrine/orm/Proxies failed to open stream /Proxy/AbstractProxyFactory.php on line 209

I'm try to move symfony to shared host.I moved symfony structure to / and my web folder is /public_html. Warning: require(/home/user/app/cache/prod/doctrine/orm/Proxies/__CG__UserBundleEntityUser.php): failed to open stream: No such file o

Python3 and pandas

Python3 and pandas

I have checked some other SO answers and googled somewhat extensively and cannot seem to find someone who has asked/answered this:I am running Ubuntu 12.04.I have python2.7 and python3.2 installed.(I ran sudo apt-get install python-numpy, p

Clear R Console programmatically [duplicate]

Clear R Console programmatically [duplicate]

Possible Duplicate: Function to Clear the Console in R Is there a way to invoke the Clear Console (Ctrl+L) menu command programmatically? 1:I use a function for doing that, and actually have put it in {R directory}\etc\Rprofile.site so