How do I delete a Git branch both locally and remotely?

How do I delete a Git branch both locally and remotely?

I want to delete a branch both locally and on my remote project fork on GitHub.Failed Attempts to Delete Remote Branch$ git branch -d remotes/origin/bugfixerror: branch 'remotes/origin/bugfix' not found.$ git branch -d origin/bugfixerror: b

Using SQLite in a Python program

Using SQLite in a Python program

I have created a Python module that creates and populates several SQLite tables. Now, I want to use it in a program but I don't really know how to call it properly. All the tutorials I've found are essentially "inline", i.e. they walk throu

Why would the size of a packed structure be different on Linux and Windows when using gcc?

Why would the size of a packed structure be different on Linux and Windows when using gcc?

In the code below, why is the size of the packed structure different on Linux and Windows when compiled with gcc?#include #include // id3 header from an mp3 filestruct header{ uint8_t version[ 2 ]; uint8_t flags; ui

How to programmatically trigger fancybox with an inline div?

How to programmatically trigger fancybox with an inline div?

I want to make a fancybox appear when someone tries to submit a form. So I've got this:$('#login-form').submit(function(e) { $.fancybox({ content: 'Hello Fancybox', modal: true }); return false;});Works good, but I'd

What is the _REENTRANT flag?

What is the _REENTRANT flag?

which compiling a multithreaded program we use gcc like below:gcc -lpthread -D_REENTRANT -o someprogram someprogram.cwhat exactly is the flag -D_REENTRANT doing over here? 1:Defining _REENTRANT causes the compiler to use thread safe (i.e

When is Java 6 end of life? (In the context of writing developer tools) [closed]

When is Java 6 end of life? (In the context of writing developer tools) [closed]

BackgroundThis is not as immediately obvious to figure out as you would think.First off, while Oracle has stopped public support of Java 6 as of Feb 2013 but with Premier support going out to Dec 2013 and Extended support going to Dec 2016

Jupyter: can't create new notebook?

Jupyter: can't create new notebook?

I have some existing Python code that I want to convert to a Jupyter notebook. I have run: jupyter notebookNow I can see this in my browser:But how do I create a new notebook? The Notebook link in the menu is greyed out, and I can't see any

Using Python, how do you untar purely in memory?

Using Python, how do you untar purely in memory?

I'm working in an environment where I can't save anything to disk. I need to be able to pull tar files and unzip them without saving to disk. This seems to fail:I've tried this but it tosses errors:# fetch.pyfrom cStringIO import StringIOim

Autocomplete text input for HTML5

Autocomplete text input for HTML5

I know there are a lot of javascript solutions, but is there an HTML5 method of having a text input with autocomplete? The datalist element is almost what im after, except it allows you to enter custom values rather than limiting you to wha

Bootstrap versions and browser compatibility

Bootstrap versions and browser compatibility

We are currently developing an application that will have to run on older corporate PCs that still have IE6 installed. I have been looking around a bit, but I cannot find a clear answer for the following: is there a link where different boo

Ruby - Digest::Digest is deprecated; Use Digest

Ruby - Digest::Digest is deprecated; Use Digest

I've been getting this warning whenever I run my tests or start rails server.When I run grep from .rvm folder I see the following:grep -R 'Digest::Digest' ../rubies/ruby-2.1.0/lib/ruby/2.1.0/openssl/digest.rb: warn('Digest::Digest is deprec

What is jQuery (edge) in jsfiddle.net?

What is jQuery (edge) in jsfiddle.net?

In jsfiddle.net if one choose framework as jQuery or Mootools they will get an option for choosing jQuery ( edge ) and Mootools( edge ).I googled it quite a bit but did not get any good answers. My questions areWhat are those versions?How a

Client side scripting and Server side scripting languages

Client side scripting and Server side scripting languages

What scripting languages comes under client side and what and all comes under server side?If JavaScript is scripting language, then what about jquery. jquery is nothing but javascript library rite? so jquery is client side scripting? I gogg

Updated to OSX 10.9, now getting ruby error using homebrew

Updated to OSX 10.9, now getting ruby error using homebrew

Updated to Mavericks and updated Xcode. Now I am getting this error when trying to use brew. $ brew cleanup/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': /usr

What “SecretKeyFactory not available” does mean?

What “SecretKeyFactory not available” does mean?

What's wrong with this?for (Object obj : java.security.Security.getAlgorithms("Cipher")) { System.out.println(obj);}javax.crypto.SecretKeyFactory.getInstance("AES");This is the output (JDK 1.6 on Mac OS 10.6):BLOWFISHARCFOURPBEWITHMD5ANDDE

Why there is number two in J2EE name?

Why there is number two in J2EE name?

As dicussed about the name here, I wonder why we have the number two 2 in the name J2EE? Was there J1EE or J0EE? 1:From Java Ranch Sun went through a name change a little bit ago. The first release of Java was called simply Java. Then

Is there a “best” or most popular database for standalone Java app?

Is there a “best” or most popular database for standalone Java app?

Is there a "best" or more popular database for standalone Java app?I'm currently writing by hand, but I would like to know what is commonly done, if there is something that is commonly done.update: talking about small app (may grow, but its

DistributionNotFound error after upgrading pip

DistributionNotFound error after upgrading pip

In reading about virtualenv here I realized I didn't have pip 1.3+, so I ran pip install --upgrade pip and now when I run pip --version i get the following:Traceback (most recent call last): File "/usr/local/bin/pip", line 5, in from p

Deepzoom for WPF [closed]

Deepzoom for WPF [closed]

Are there any ports to WPF of Silverlight's MultiScaleImage (aka DeepZoom)? Have Microsoft road-mapped this at all for WPF?I want to move from WinForms to WPF and require something like DeepZoom, using Silverlight isn't an option. 1:At

Determining 64-bit vs. 32-bit Windows

Determining 64-bit vs. 32-bit Windows

I'd like to configure visual studio 2005 to copy .dll's based on whether the OS is 64-bit or 32-bit during a build.I do not want to specify what the platform target is. My first attempt was to use a batch file to lookup the Windows version

Can I upload Xcode builds on macOS 10.12

Can I upload Xcode builds on macOS 10.12

Will I be capable of submitting an app with Xcode 7.3.1 while on the macOS 10.12 beta? According to this post, it is possible to run Xcode 7 alongside macOS 10.12. 1:Yes, you can! But if you're tying to do this, you will find two proble

Difference between VsDevCmd.bat & vcvarsall.bat in VS2012

Difference between VsDevCmd.bat & vcvarsall.bat in VS2012

What's the difference between:VsDevCmd.bat (Developer Command Prompt for VS2012)vcvarsall.bat (VS2012 x86\x64\ARM Native\Cross Tools Command Prompt)I have a pretty good understanding of vcvarsall.bat as it's been part of Visual Studio for m

Unable to determine the provider name for provider factory of type 'System.Data.SQLite.SQLiteFa

Unable to determine the provider name for provider factory of type 'System.Data.SQLite.SQLiteFa

I am getting this error with the Nuget package for SQLite 1.0.94.1. I fiddled around with the various app.config sections, helped by similar questions about previous versions of this package, but I cannot get it to work. Below is the app.co

why Python 3 needs wrap dict.items with list()

why Python 3 needs wrap dict.items with list()

I'm using Python 3. I've just install some Python IDE and curious about following code warning:features = { ... }for k, v in features.items(): print("%s=%s" % (k, v))Warning is: "For Python3 support should look like ... list(features.ite

How to find version of Drupal installed

How to find version of Drupal installed

How can I know which version of Drupal is installed in my server? 1:You can get this by logging in to admin. Go to Administer → Reports → Status Report.This will let you know all your config information of the site including your Drupal